©2019 by MBD - Mini Bike Drags. Proudly created with Wix.com

General Discussions

Share stories, ideas, pictures and more!
 Views
1Posts

Events

Post pictures from your events, times, people, things & bikes
 Views
4Posts

Frames

Frame building, welding, hardware, jackshafts, steering, general stuff
 Views
0Posts

Engines

Building a motor, specs, tolerances
 Views
2Posts

Rims & Tires

Rims, tires, bearings, axles
 Views
0Posts

Jackshafts, Axles, Brakes

How to setup the stuff, where you can find them online, prices, vendors, etc.
 Views
1Posts

Build logs

How it gets done, start to finish, sketches, designs, specs & finishing
 Views
1Posts

Times, Speeds, HP

Your best time, speed or runs. Don't BS people, just the facts on your runs with slips or GPS screen shots.
 Views
1Posts

Dyno runs & pulls

If you have access to a dyno, let us know about it. Describve the mods you have, list the pull, so others can see it.
 Views
0Posts

Classifieds

Parts to whole bikes. Be honest, specific, price fairly, spammers will be banned.
 Views
0Posts
New Posts
  • It's getting to be soon, here's a video link for you to watch with some good stuff. https://www.facebook.com/JoesMinibikes/videos/2415992505290846/UzpfSTQ2NjUzMjM4MDAyNTY3ODpWSzoyNDE1OTkyNTA1MjkwODQ2/
  • After pushing my luck with the red bike engine, I've decided to build a better motor. Some of the parts will be from the first one, other parts will be new. For now I'm planning on using the same block, Bullfrog piston, ARC rod & flywheel, head (the new one I just installed) & the Black Mamba cam. I've sent for some stainless steel valves from ARC, with new springs, keepers & retainers. I don't trust the stems on the original valves, as they're pretty thin up top & I've pushed them too hard at this point to trust them. If I break a stem at the top, even at a low speed, the valve will drop into the piston & the motor would be completely destroyed in one turn of the crank. The new valves should take care of this potential problem before it happens. I had a 60363 motor from a sale last year, so today I stripped it down. One thing I'm planning on doing is replacing the crankshaft in the new build. I had "fixed" the first crank by sanding it down by hand, as it was about .005" out of round. It was a real PITA & took a lot of time & effort to make it right. This worked pretty well, but I'm not going to take any chances with this build. I checked the crank on the new motor & found it's pretty close to round, only out by about .0005" as close as I can measure, so it's going to be a keeper. It will be much easier to just install new bearings & put it back together. I've been looking into balancing this motor, as the original one had a bad case of the shakes which would go away at higher rpms, but it was pretty uncomfortable when it got into the speed where it vibrated badly. You either wanted to run faster or slower, but not in that rpm range. I'll be checking the Bullfrog piston for weight as a part of the balance, but I ran the numbers with the stock piston, crank & rod, just to see where this motor comes in from the factory. The piston, rings, wrist pin & clips weighs in at 201.8 grams. The small end of the rod is 32.6 grams. The amount of mass needed to counter-balance the crank & rod for stability is only 59.2 grams. Not a lot of weight really, compared to the piston. The "normal" balance factor for a single cylinder engine is about 50%. This can vary up or down by a few percent due to cylinder angle & a bunch of other stuff, but the 50% number is typically considered to be what works well. When I ran the numbers for the factory piston, rod & crank, it came out to only a 39% balance factor, so it's not too good from the start. They build this motor way out of balance at the factory. Can't wait to see what it looks like with the Bullfrog piston set up to run. I'm thinking that the Bullfrog piston is heavier than the stock one (not sure about that yet), which would explain the bad vibration problem I had. I'll get back on this as I find out more & start taking down the old motor.
  • Slow to gain members & learn this web software, so I'm putting in a post about the motor on the red bike to show what I did & at least have one post in this area. Please bear with me on the software, it's a PITA to learn. I started with a stock Predator 60363 (hemi), not the conventional motor (wedge head) for a couple of reasons. The hemi has larger factory valves, a hemispherical combustion chamber and heavier 5.5mm valve stems. It's the same basic block, but the head should flow a bit better in general and can make decent horse power. There's a bunch of people who don't like this motor type, but I decided to go with the hemi style anyway. It turned out to be a good choice for me. Here's the basic motor build Black Mamba cam 0.275" lift, 26# springs, chromoly pushrods Bullfrog's pop-up 11:1 piston + 0.020" ARC billet rod 0.027" head gasket ARC billet flywheel with 32 degree advance 22mm Mikuni VM22-133 24" X 1" OD header I used studs for the head & block side cover. They're glued in with red Loctite, so it's a bit better than the factory bolts for clamping & holding pressures. So far it's holding & working well, no leaks yet or blown gaskets. The biggest problem I had with the build had to do with the main journal on the crank. It was ground out of round by about .004"-.005". Wonderful Chinese precision on the journal, to be sure. Nominal is 1.188" diameter for the ARC rod & bearings, but this one varied from 1.189" to 1.194" so it was egg shaped from the factory. I sanded it by hand with WD40 & Wet-Dry, paper to get it as close as I could. It took for ever, but I'm glad I used the plastigauge & digital caliper. This motor would have been junk the first time it was fired & wound up too tight. I finally got it within about .002" at all spots & called it good. I spoke with an engineer at Bonneville from the Indian Motorcycle Company about it that year. He said with the slight out of round, it would act like a paint brush wiping the crank, but as long as the lubrication was good, it should work. He seems to have been right. Since I don't turn sustained high rpms, so far it's running ok up to 8400. I'm running Mobil 1 in the 5W-30 type with good results, but I should still send in an oil sample to a lab see what's really happening inside this motor. The crank endplay ended up at about .010", which is just about right. Too tight & it will blow the side cover gasket, too loose & it can move around too much and wreck things in a pretty nasty way. I made a crude end-play gauge with a Horrid Freight dial gauge that attaches to the block. It's good enough to give a true reading, close enough for one of these motors spinning well under 10,000 rpms. I did a little work inside the intake & exhaust runners. nothing too radical, just smoothed out the edges, opened up the shelf areas a bit & then lapped the valves to make sure they were tight on the seats. I didn't change things too much (my first attempt at porting) but did remove enough metal to open the runners a bit without slowing down the airflow by getting things too big for midrange torque. If you open the runners too much, it can help some with the top end, but you will sacrifice some of the mid range due to lower air speed through a bigger hole. It pulls pretty well from about 4500 & up. Had to grind the crank a bit to avoid the cam, just a freehand job on a belt grinder, but it's enough to pass & not hit as it swings past the tight spot. The piston in place, checked deck height & valve to piston clearance. There's enough so far. This piston is cut for much bigger valves than I'm running now, the stock valves look small compared to this cutout. The squish area at the edges ended up between .040' & .050" with a .027" head gasket, so that's where it stays. There's .060" at the intake and more at the exhaust valve with the factory head torqued in place. All I did was lap the head on a sheet of glass, to make sure it was really flat for the gasket. Made a pulley/tightening setup for the flywheel nut. This keeps things in place so the crank can't spin when tightening the nut with the amount of force it needs. Here's the motor prior to hanging the fan shroud. The carb in the picture is the VM22 "Chikuni" I started with, but it was soon switched over to the genuine Mikuni. Much easier & faster to swap-out jets on the real one, much better made in general. You don't have to drop the entire bowl on the real one, just unscrew a bolt, replace the main jet & then replace the bolt. I'm still running the stock ignition & it works pretty well. No trouble with it at this point, so I'll keep it going as long as it's still doing the job. Not sure what the upper limit is with a factory coil. Anyone know? I was shooting for a reliable modded motor with more HP & higher rpms. This one seems to be doing the job pretty well so far with no leaks, problems or disasters. I buy 110 octane VP leaded fuel, then cut it 50% with 87 octane unleaded. This combination gives me about 99 or 100 octane, so it has never pinged or knocked. Not sure I'd want to have this happen at 8000 rpms... Here in Raton I'll just go to the airport & buy AV gas to mix down to 100 octane, better safe than sorry. Running in Tucson & Phoenix I was using a 130 main jet, after moving to Raton at 6,500' I've had to drop down to a 110 main jet, but it's pulling pretty well, even with the thinner air. After a couple of real runs, I'll pull the plug to see how it looks. At least it won't get up to 115 this summer, maybe 95 a day or two, but that's about it for heat.